Abfrage einer Script-Version in WordPress

Nicht selten werden Scripte innerhalb von Plugins und Themes verwendet. WordPress bringt im Standard eine ganze Reihe an Frameworks mit und warum diese also nicht einbetten, statt es extra im Plugin abzulegen und damit nicht selten verschiedene Versionen von Frameworks laden. Nicht unbedingt gut für die Funktion, geschweige denn für Performance und Ladegeschwindigkeit.

Trotzdem ist man manchmal von einer bestimmten Version eines Frameworks abhängig. Daher bietet es sich an, die Version des Scriptes abzufragen und alternativ das entsprechend erwünschte Script zu laden. Der folgende Syntax macht das am Beispiel Prototype.


// Ersetzt Prototype mit Version 1.6, wenn kleiner 1.6
if ( $wp_scripts->scripts['prototype']->ver < 1.6 ) {
	
	wp_deregister_script('prototype');
	wp_enqueue_script('prototype', '/wp-content/plugins/pluginpfad/prototype.js', NULL, 1.6);
}

Mehr zu den verwendeten Funktionen findet man in der /wp-includes/script-loader.php.

One Comment

  1. Hallo zusammen,

    möchte man einen Geschwindigkeitsschub bspw. erleben, kann man ja mal in der besagten Datei /wp-includes/script-loader.php die Zeile $this->default_scripts(); auskommentieren.

    Danach lässt sich der Admin-Bereich wunderbar zügig bedienen 😉

    Grüße,
    Christian

Comments are closed.